Mini PC Forum - ACEPC

Full Version: T11 and Auto Power-on
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I recently purchased one of these Mini PC's because of the SATA interface and 4GB of onboard memory. I also needed an x86 processor - not ARM for a particular project using Linux and ROS (Robot Operating System). 

This machine worked great - even with 32GB eMMC since Linux only required about 5GB. The only challenge was the need for auto power-on. I downloaded the RAR files that Willis provided. Since I had already installed Linux over Windows, I created a custom WinPE image (to boot from USB drive) with the BIOS files from the RAR archive copied into the image.  

After booting to WinPE and updating the BIOS, I powered off the computer and noticed that there wasn't a new power setting in BIOS. What I DID notice, was that the T11 turned on as soon as power was applied to it! Success!

Thank you for the excellent support ACEPC - you have a great Mini PC that is incredibly versatile. The T11 is running several of my research robots without noise, heat or any issues. It's, quite literally, flawless with Linux (Ubuntu 18.04) and ROS (Melodic). The quad-core Z8350 runs all services and applications without issue. 

I noticed that someone previously wrote that the BIOS package bricked their T11. I'm unsure what might have happened with their upgrade, but I can confidently say it worked well and made a critical difference in my ability to continue using these computers. I'll now recommend the ACEPC T11 to my colleagues and I'll continue purchasing them and placing them into more of the robots and other embedded applications that we're building. 

Thanks again ACEPC!

Jeff D.
I upgraded the BIOS within linux using flashrom and it went just fine. The version that is included with Ubuntu 18.04 did it just fine but has a warning about being an untested configuration, but worked perfectly.

Before that I tried the flash package for Windows which didn't work.
@squash Would you mind sharing the steps on how to flash your BIOS through flashrom? I have xubuntu 18.04 installed and currently trying to figure out where to start and not getting my box bricked.

How to verify that my chipset is supported by flashrom? Thank you.