Mini PC Forum - ACEPC

Full Version: T11 CPU Speed problem, 0.48GHz, 1.67GHz - never 1.92GHz
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I just got a T11 and it seems to work OK, except that I notice the CPU burst speed is not living up to what the ATOM x5-Z8350 is supposed to deliver.

Most times the CPU speed fluctuates due to load, which is normal, but when heavily utilized it only registers a top speed of 1.67GHz, not the 1.92GHz that this chip is supposed to do. More troubling, is at some random times the speed drops down to 0.48GHz max, and there is a real noticeable slowdown in performance like jittery HD video decoding which normally works fine when it is above 0.48GHz. I don't know if this system is underclocked, or maybe has some other performance limitations that causes these slower CPU speeds?

I have other systems and CPUs and they have all reported correct top burst speed (like 1.86 or 2.48, etc) and performed accordingly.

I am thinking I might have a defective unit but not sure if there is any other issue causing this CPU speed problem that anyone is aware of.
(10-03-2018, 09:31 AM)jondo Wrote: [ -> ]I am thinking I might have a defective unit but not sure if there is any other issue causing this CPU speed problem that anyone is aware of.

Before going down that road, what App are you using to benchmark the W5 to show it's performance etc? 

I have a T11. and would be willing to run a test on mine using the same program. Also have you made any changes to the boot order, added any extra disks in the lower compartment etc? What is the complete breakdown of how you have it set up and the app used to generate your numbers and we can compare notes.

(10-04-2018, 08:02 AM)dardwizzle Wrote: [ -> ]Before going down that road, what App are you using to benchmark the W5 to show it's performance etc? 

Nothing fancy, no benchmarks, just the Windows task manager CPU activity. Usually have that always running on a system to see what's going on, gobbling up the CPU or hard drive, etc.

This is just stock T11. I did all upgrades and even went to Windows 1803, but got blue screens so I restored the factory image with the ACEPC boot/restore image and went back to Windows 1709 upgraded, seems more stable. I did try a HD in the SATA bay, but took it out because it shuts off the disk hard with a loud click when the system powers down, so will probably wait till I get a SSD instead.

Again, this is just stock Windows task manager. Other systems show correct CPU frequency, like another one I have with Braswell Celeron N3060 shows varying speed and burst up to 2.48GHz when loaded as it should. Also have a Bay trail system which shows correct burst speed. Never had a Cherry trail system and never had a Atom x5-Z8350 before, but I assume it should show correct frequency up to 1.92GHz when loaded.
I would definitely have another look at your CPU utilization under heavy load like using a stress test app of benchmark app. I just ran "UserBenchmark" on my T11 while watching the CPU utilization and I was able to see if go from 1.4 GHz up to 1.9 GHz. Keep in mind that it will only go up to that if the Turbo kicks in which it should do under full load. One thing that you may be seeing in the default task manager is likely the average Turbo Speed. When I run a stress test using UserBenchmark, the test results from that app show that my top average speed is 1.67GHz which is what your seeing in the default Windows Task Manager. I was able to see my speed using the same task manager hit the 1.9Ghz, but you had to really pay close attention because it would only hit it for a split second and then change again. So I would bet that your system is running exactly as it should and you are getting the proper speeds. Please keep in mind that the top speed is NOT a set speed, it is nothing more then the max speed your CPU can use when Turbo kicks in when the load is high. The chances of it ever holding that speed for more then a split second are slim to none.

I am running Windows 10 Pro on mine, but that should not matter. Also, putting an SSD in the bottom bay of the T11 will do you little good because the drive connection there while it is a SATA, its a SATA1 over USB, so it's not a true SATA port and will not give you any performance. That bay is strictly for adding a secondary drive.

I hope this help you!
Thanks for checking on your end.

So it seems the 1.67GHz would be the correct top reported speed in Windows task manager for the Atom x5-Z8350. Different behavior than some Bay trail and Braswell systems I was comparing to that regularly stayed at the top burst freq. I did try booting to Linux and I did observe there that the CPU freq did go up to 1.92GHz in quick bursts.

But I think I might have to return this thing while I still have time. The main problem is when it drops down to the minimum 0.48GHz and stays there, and I haven't been able to narrow down what is causing that. When it does, performance is severely degraded like h.265 HEVC decoding is garbled and slow, unlike when the CPU is running at normal speed. I did try disabling intelppm in the registry and that caused the CPU to be locked at 1.44GHz all the time. That's not bad, but I'm not sure if that is an acceptable workaround. I also have tried reinstalling Windows and Cherry trail drivers, Windows updates and other settings. But the  CPU speed problem combined with the blue screen crashes on Windows 1803 don't make me feel comfortable about keeping this thing.

Too bad, was a nice small cheap box with lots of features. But I had better luck with major brands like Acer or Asus without these small little annoyances, so for now, just return this and maybe try later if the issues can be worked out.
Sorry to hear your still having issues, I certainly haven't run into any of those issues myself, but then again, I am also running Win 10 Pro, as I am with all my devices so this could be something with Windows or perhaps you did get a bum unit.. while the T11 is not my first choice of devices, for me its a perfect device for a Smart TV box
For a few days haven't seen it drop down and get stuck at 0.48GHz. Not sure what has changed that, be it restoring Acepc factory image, reinstalling Cherry trail drivers, performing Windows updates for 1709, etc. I still have version 1803 blocked.

I guess I'll keep this thing. Heck, its only $130 bucks. If this stays stable, I'll make an image of it and then try upgrade to 1803. The first time I let Windows do that on its own and then had blue screen crashes, reverted to previous Windows 1709, and then the system was corrupted and had to restore factory image.
I can't honestly thing that this has anything to do with Windows... I say this only because the device and its hardware is really not tied in anyway to any windows version... That being said. If you would like to try using Windows 10 Pro, I can help you upgrade to pro completely legally with no cost to you what so ever. Should you choose to return the device and possibly try one of the others that will allow you much more configuration options (The T11 does not allow you to change the boot drive which would give you a much larger C drive allowing you to do far more with the device.) Let me know. You can friend me on Facebook so that we can chat in real time instead of waiting for a reply here in the forums, let me know.

Unfortunately, ACEPC does have little support for their products, but if you get the chance to chat with someone like myself who has a lot of knowledge working with these devices, we are are certainly willing (at least I am) to work with you to get the most out of your devices, please let me know.

I personally own 3 ACEPC devices, and I have found them, especially for the price to be great devices. As well, I have on order a couple of other MiniPC's to see how well others work compared to my ACEPC devices. I also purchased a "Mini Form" MiniPC for my parents which is a Fanless PC and they love it, granted due to the lack of a large enough drive, they use it strictly for web surfing which is all they do with it anyway.

For reasons I can't discuss here, I am quite partial to ACEPC's mini PC's, but for a little ore $ there are many other manufactured that will do everything you need or want to.

I am still perplexed though where your BSoD are coming from, because there should be no reason for that and honestly i have yet to see that happen on any of my devices regardless of which Win versions I am running, so there could be any number of reasons for that, but unless its a bad configuration on your part or the rare possibility that you did get a bum device, I just cant see why your getting them...

Let me know if you want to friend me on FB and I will PM my info to you.. I really want to help you out..

The Solution to this problem is the windows power settings.
Step one: set your computer to high-performance mode if
step one works then that's it. if it only gives you balanced mode then go to step 2

Step two: g Use Regedit and change the registry key below:
Change the value of CsEnabled from 1 to 0  and reboot

Step Three: go to step one after going to the advanced settings in performance mode set min and max CPU to 100%

Thanks to MagicCigam1 for figuring this out 

This worked Great for me I hope this helps